{0x00} Phoenix模块开发教程:准备阶段

Phoenix是使用Java进行开发的插件框架,因此,标准的Phoenix插件也需要使用Java进行开发。
在进行Java开发之前,我们需要准备好JDKIDE.

0x01 准备JDK

这篇文章属于Phoenix Framework 入门教程的一部分。

Java Development Kit,就是我们平时所提到 JDK,是开发 Phoenix模块所必须的。

由于Phoenix使用了Java8进行编写,因此你只能选择Java8或其以上的JDK版本。
同时,要想正常使用Phoenix,你也必须使用Java8或其以上版本的JRE. 旧版本的Java(如Java7)是无法运行Phoenix的。

下载

访问Oracle的Java SE Development Kit 8 Downloads页面,你可以下载到最新版本的Oracle JDK8.
让我们翻到下面的Java SE Development Kit 8u***,这里提供了各种平台的下载地址。

在下载Oracle的Java之前,你需要同意并遵守他们的协议,即《Oracle Binary Code License Agreement for the Java SE Platform Products and JavaFX》。
选中Accept License Agreement表示你同意协议,然后在下面的表格中找到适合你系统的JDK安装包,点击下载。

举个例子,如果你是Windows 10,并且是x64的系统,那么可以下载Windows x64对应的那一项。

白痴环节

如何知道自己的系统是64位还是32位?

推荐阅读: tdiant:查看电脑系统位数

安装

推荐阅读: tdiant:配置JDK

0x02 准备IDE

IDE是集成开发环境的简称,一个集成开发环境为开发者提供了许多在开发过程中需要用到的实用功能。
Java的集成开发环境有很多,比如IntelliJ IDEA,Eclipse,NetBeans等等...
这里简单介绍一下IntelliJ IDEA
IntelliJ IDEA是一个非常棒的IDE,关于它的安装教程,网络上已经有了一些很好的教程。

推荐阅读: 【工具安装和配置】IntelliJ IDEA安装

立刻订阅 Lss233's.Blog()

保持最新! 将所有最新和最棒的帖子直接发送到您的邮箱

或者订阅 我们的RSS!