Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

  1. Emergency 911
  2. Alice 97 625 999
  3. Bob 91 12 54 26
    In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题解

题目会输入一组数字。要求任意一组数字不得是另外一组的前缀。
比如说:

91125426
911

或者

812345
8123456

这样的话只需要线段树在插入的时候,判断经过的节点是否被标记为 end
或者在插入结束后,判断最后一个节点是否为第一次被插入就好了。

另外,本题的内存限制比较小,
所以在一组数据的结束,需要释放内存(就算你不说我也会这么做的,因为一个 delete 清空字典树超方便呀)。

#include <bits/stdc++.h>
const int MAX_CHILDREN = 11;
struct node
{
    bool end;
    node *children[MAX_CHILDREN];
    int count = 0;
    ~node() {
        for (int i = MAX_CHILDREN - 1; i >= 0; i--)
        {
            if(children[i]) {
                delete children[i];
            }
        }
    }
    node()
    {
        end = false;
        for (int i = 0; i < MAX_CHILDREN; i++)
            children[i] = NULL;
    }
};
node *root;
bool yes = true;
/**
 * 插入一个新的字符串
 * @param str 字符串数组
 * @param len 字符串长度
 **/
void insert(char *str, int len)
{
    node *location = root;
    for (int i = 0; i < len; i++)
    {
        if (!yes)
            return; // Thereisnoneed.
        if (str[i] == 0 || str[i] == '\n')
            continue;
        int id = str[i] - '0';
        if (location->children[id] == NULL)
        {
            location->children[id] = new node;
        }
        if (location->end)
        {
            yes = false;
            return;
        }
        location = location->children[id];
        location->count++;
    }
    location->end = true;
    if (yes)
    {
        yes = location->count == 1;
    }
}
char str[20];
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        root = new node;
        yes = true;
        int n;
        scanf("%d", &n);
        while (n--)
        {
            scanf("%s", str);
            int len = strlen(str);
            insert(str, len);
        }
        printf("%s\n", yes ? "YES" : "NO");
        delete root;
    }
}